Page0001

Uputstvo za integraciju ERP PANTHEON-a 55 sa fiskalnim printerom Professional
Nakon uspješno završenog posla integracije ERP PANTHEON-a 55 sa fiskalnim printerom Professional, firme Mikroelektronika a.d.,
Banjaluka , te više nivoa testiranja, pred Vama je uputstvo za podešavanja integracije ERP PANTHEON-a 55 sa fiskalnim printerom
Professional. Sva podešavanja možete izvršiti u samo nekoliko koraka, i u veoma kratkom vremenu imati gotovo rješenje i PANTHEON
spreman za rad sa fiskalnim printerom Professional.
Podešavanjima se pristupa preko panela POS.
Nakon toga otvara Vam se prozor za POS, gdje pritiskom na tipku
Postavke,
otvorite prozor za podešavanja fiskalnog printera.


Page0002

Na novootovrenom panelu

Postavke
, nalaze se četiri tipke
POS dokumenti
(ALT+F1),
POS printer (ALT+F2),
Prikazni ekran
(display) (ALT+F3),
Fiskalni printer
(ALT+F4), kojima
zasebno prilazimo podešavanjima.
Pritiskom na tipku Postavke, zadano pristupate podešavanju
POS dokumenti , gdje je neophodno, pored zadanih postavki,
uključiti opciju
„Dozvoljen ispis samo nepotvrđenih POS
dokumenata“.


Page0003

Na panelu
POS printer
nisu potrebna dodatna podešavanja, pored zadanih.
Na panelu
Prikazni ekran (display),
nisu potrebna dodatna podešavanja, pored zadanih.
Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju
„Upotreba fiskalnog printera“,
sa padajućeg menija
Fiskalni printer
, odabrati


Page0004

„

Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju

"Mikroelektronika professional
“, te pored navedenog označiti putanju direktorija za print u
folder
C:\temp
i putanju direktorija za log „
C:\temp" “,to je
folder gdje se šalju file-ovi za
printanje i gdje se smještaju log file-ovi. Dodatna podešavanja kao što su
podešavanje prelaska
na ljetno ili zimsko računanje vremena, poreske stope, jedinice mjere, tekst za kupca i naziv trgovine , možete
izvršiti sa tipkama koje se nalaze desno na ovom prozoru.
Opciono možete izabrati upotrebu numeričkih PLU šifri
u zavisnosti od vaših potreba, ukoliko

ova opcija nije uključena, koriste se alfanumeričke šifre, odnosno šifre iz PANTHEON-a.


Page0005

PLU šifre se unose u šifrantu artikala na označenom polju

PLU šifra.
Na slici ispod imate primjer kako izgeda jedan POS račun spreman za slanje na fiskalni printer.


Page0006

Te kako izgleda jedan maloprodajni fiskalni račun i maloprodajni reklamirani račun.
Pored ispisa maloprodajnog fiskalnog računa u PANTHEON-u je i dalje mogu i ispis računa na
A4 printer, desnim klikom miša na tipku F8-ispis, a da se pri tome dokument ne potvrdi, dokument
se potvrdi lijevim klikom miša na F8 – ispis, time se račun pošalje na fiskalni printer.


Page0007

Kod plaćanja u ovisnosti, da li se plaća gotovinom, kreditnom karticom, vrimanom, sa padajućeg

menija
“Načini plaćanja, na POS-u nakon pritiska na tipku F7-plaćanje, označite vrstu plaćanja kojom se izvršava plaćanje.
Ukoliko određeni način plaćanja nije na listi, to podešavanje izvršite u šifrantu „
Načini plaćanja ", koji se nalazi na ,
sljedećoj lokaciji,
gdje za „Slip tip
“,kod gotovine označite – 0, kod
čeka – 1, kod kartice – 2, kod virmana-3.


Page0008

Dodatne komande kao što su

stavljanje i uzimanje depozita, presjek stanja, zaključak
fiskalnog printera, peridočni izvještaji
mogu se izvršiti desnim klikom miša na
čarobnjak.
.
*Na kraju nekoliko napomena:
Zbog načina rada F-linka i obaveze jedinstvenih (unique) naziva u pomoćnom programu PGM-u,
odnosno u memoriji fiskalnog printera, u PANTHEON-u je urađeno takvo rješenje da se naziv
artikla u memoriji fiskalnog printera, sastoji od: ¨šifra artikla_naziv artikla¨ (PANTHEON siječe
sa desne strane višak) , znači šifra artikla+naziv artikla i onda PANTHEON siječe sa desne strane
na 29 znakova, jer je maksimalan broj karaktera naziva artikla u F-linku 32 karaktera, što je u
ovom slučaju naziv artikla – 29 karaktera + 3 karaktera
/JM
(jedinica mjere) = 32 karaktera.
To bi na primjeru jednog artikla sa dužim nazivom, ovako izgledalo:
Ukoliko je Naziv artikla: ¨sok cappy juice 2L mix vitaminski 2l pakovanje¨ , a njegova PA šifra
“1234567890123456” (max. dužina šifre)
Njega PANTHEON siječe na ¨1234567890123456_sok cappy ju¨
Ovdje je riječ ukoliko je dužina šifre 16 karaktera (maksimalni broj karaktera za šifru), ovime se rješava
problem sa istim nazivima u F-linku koje on ne prima i napravi korisnicima zbog toga problem.
Znači makimalan broj karaktera koji se ispisuje na računu i dalje ostaje 29 , zbog F-linka, jer on prima 32,
29+/JM (jedinica mjere – 2 znaka) !
Ovime se rješava problem istih naziva u fiskalnom printeru, koji je mogući, zbog artikala sa dužim
nazivima, do 40 znakova, a tipa od 25-og do 29-og znaka, ponavljaju im se ti dijelovi naziva tipa
cappy juice 2L mix vitaminski 2l pakovanje
cappy juice 2L mix vitaminski 3l pakovanje
cappy juice 2L mix vitaminski B pakovanje


Page0009

Zbog zahtjeva F-linka za zaokruživanjem izračuna cijena na 2 decimale, neophodno je ovome prilagoditi i PANTHEON, kako ne bi dolazilo do toga da

total plaćanja nije isti kao što printer zaokružuje, i onda se dešava da račun ostaje otvoren i čekaće na uplatu dodatnih 0.01 ili slično KM.

Ovo se dešava ukoliko u Administratorskoj konzoli u postavkama za Preduzeće\Zaokruživanje imate postavljeno zaokruživanje izračuna cijene na 4 decimale-prva postavka, te zaokruživanje pozicija - POS na 3 ili 4 decimale.

Kako bi ovo izbjegli, potrebno je uraditi jedno od 2 moguća rješenja:

1.      Ukucavati direktno maloprodajne cijene (a ne da se preračunava mpc - preporučuje se postaviti prikaz cijene na 4 decimale tako

da ćete znati da je dobro upisano)

ili

2. Postaviti zaokruživanje izračuna cijene [image] na 2 decimale tako da i kada bi kucali vpc u šifrantu uvijek bi dobili mpc zaokuženu na dvije decimale.

Poenta je dakle da na neki od ovih načina postignete da je MPC obavezno zaokružena na dvije decimale, i da postavka "Zaokruživanje pozicija - POS"

mora biti isto na 2 decimale podešena da ne bi došlo do odstupanja!

Na ovaj način bi trebalo biti podešeno zaokruživanje u AK \Postavke\Parametri programa\Preduzeće\Zaokruživanje

Postavke zaokruživanja zapisuju se u glavu dokumenta tako da ako testirate na jednom već otvorenom računu i promijenite postavke zaokruživanja, na istom

Dokumentu će važiti stare postavke, tako da je potrebno otvoriti novi da bi vidjeli promjene.


Page0010

Kao i što je prethodno navedeno u PANTHEON-u je omogućen rad kako sa PLU šiframa (numeričkim), tako i sa PA šiframa

(alfanumeričkim), kako to izgleda u fiskalnom printeru (memoriji fiskalnog printera) - unos ovih artikala, prikazano je na slici ispod:
Artikli sa
PLU šiframa (numeričkim)
Artikli sa
PA šiframa (alfanumeričkim)
Rad sa plu šiframa je brži u odnosu na rad sa pa šiframa, što je jedna od prednosti korištenja plu šifara, koje unosite
u šifrant artikala u polje predviđeno za plu šifre, mada je na korisniku da odluči koje će šifre koristiti u svom radu.


Page0011

Za podešvanja F-linka na raspolaganju Vam je uputstvo na sljedećoj lokaciji,
http://www.mikroelektronika.net/index.php?data=080810
te zadnja verzija pomoćnog programa PGM, koju je obavezno instalirati uz F-link instalaciju!
http://www.mikroelektronika.net/index.php?data=081124
Korisnička uputstva za za fiskalne kase Mikroelektronika inventa, altera i impera, fiskalni
štampa Mikroelektronika professional i GPRS terminale Mikroelektronika DTT-002/003,
možete preuzeti na sljedećoj lokaciji, kako bi ste se mogli do detalja upoznati sa načinom korištenja i svim funkcijama uređaja.
http://www.mikroelektronika.net/index.php?data=080905