Uputstvo za integraciju ERP PANTHEON 5.5. i FP555 BA i Best BA

Uputstvo za integraciju ERP PANTHEON-a 55 sa fiskalnim pisačima FP555 BA i Best BA

Nakon uspješno završene integracije ERP PANTHEON-a 55 sa fiskalnim pisačima FP555 BA i Best BA firme Kimtec d.o.o, Vitez
, te više nivoa testiranja, pred Vama je uputstvo za postavljanje integracije ERP PANTHEON-a 55 sa fiskalnim pisačima FP555 BA i Best BA .
Sva podešavanja možete izvršiti u samo nekoliko koraka, i u veoma kratkom vremenu imati gotovo rješenje i PANTHEON
spreman za rad sa fiskalnim pisačima FP555 BA i Best BA, i na taj način izvršiti obavezu fiskalizacije maloprodaje.

Podešavanjima se pristupa u modulu Roba, zatim Izdavanje, POS i na kraju 320 - Maloprodaja, ili neki drugi dokument na POS-u 321, 322,

itd. definisan za Maloprodaju

Nakon toga otvara Vam se prozor za POS, gdje pritiskom na tipku Postavke, otvorite prozor za podešavanje fiskalnog štampača.

Na novootovrenom panelu Postavke, nalaze se četiri tipke POS dokumenti(ALT+F1), POS printer (ALT+F2), Prikazni ekran (display)

(ALT+F3), Fiskalni printer(ALT+F4), kojima zasebno pristupamo podešavanjima. Pritiskom na tipku Postavke, zadano pristupate

podešavanju POS dokumenti , gdje je neophodno, pored zadanih postavki, uključiti opciju „Ispis samo nepotvrđenih POS

dokumenata“.

Na panelu POS printernisu potrebna dodatna podešavanja, pored zadanih.

Na panelu Prikazni ekran (display), nisu potrebna dodatna podešavanja, pored zadanih.

Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju „Upotreba fiskalnog printera“, sa padajućeg menija

Fiskalni printer, odabrati "HCP Fiscal Residential Gateway", te pored navedenog označiti putanju direktorija za print u folder C:\temp i

putanju direktorija za log „C:\temp\odgovor" ,to je folder gdje se šalju datoteke za printanje i gdje se smještaju auto-odgovor datoteke

fiskalnog drivera.

Dodatna podešavanja kao što su podešavanje prelaska na ljetno ili zimsko računanje vremena, poreske stope, izvršavate direktno na fiskalnom

driveru. Upotreba numeričkih PLU šifri je obavezna za fiskalni driver

HCP Fiscal Residential Gateway.


Mjerne jedinice

Zbog specifičnog načina rada fiskalnog drivera HCP Residetial Gateway sa mjernim jedinicama, neophodno je šifrant mjernih jedinica u ERP PANTHEON-u prilagoditi fiskalnom driveru, iz tog razloga uvedeno je i novo polje u Šifrantu Mjernih jedinica "Fiskalna šifra", u nastavku pojašnjenje kako ga koristiti,

Fiskalni driver HCP Residential Gateway podržava 15 mjernih jedinica, koje se šalju fiskalnom printeru u datoteci za print u formatu 0 do 14, uključujući 0 i broj 14.

Prvih 10 mjernih jedinica je zadano postavljeno u fiskalnoj memoriji, i one se ne mogu mijenjati, predstavljaju fiksne vrijednosti, kao na slici pomoćnog programa HCP Fiscal, koji vam fiskalni serviseri uz fiskalni driver postave, uz ovu aplikaciju možete provjeriti koje su to mjerne jedinice već upisane u fiskalnu memoriju, i tako isto ih postaviti u šifrantu Mjernih jedinica u ERP Pantheon-u.

To su mjerne jedinice koje počinju sa pcs - 0 oznaka sve do h - 9 (pcs - 0 , ovu mjernu jedinicu ne postavljajte u šifrantu Mjernih jedinica u Pantheon-u), kg - kilogram - 1, g - gram -2, t - tona - 3, l - litar - 4, dl - deci litar - 5, m - metar - 6, m2 - kvadratni metar - 7, m3 - kubni metar - 8, h - sat - 9, ovim nizom su i njihove oznake 0,1,2,3,4,5,6,7,8,9) , ove mjerne jedinice su fiksne i ne možete ih mijenjati u fiskalnoj memoriji, zato je neophodno da ih na isti načih postavite i u šifrantu mjernih jedinica u PANTHEON-U, polje "fiskalna šifra".

Ukoliko npr. želite u šfirantu Mjernih jedinica postaviti mjernu jedini kilogram - kg, kako bi se ispravno poslala fiskalnom driver HCP Residential Gateway, to ćete učiniti na sljedeći način, otvorićete šifrant mjernih jedinica, koji se nalazi na sljedećoj lokaciji, kao na slici ispod,

Zatim ćete pronaći mjernu jedinicu Kilogram - kg u Vašem šifrantu mjernih jedinica, ukoliko nije prethodno unešena, onda je možete ručno unijeti, te nakon toga u polju fiskalna šfira unijeti vrijednost 1, jer je to oznaka mjerne jedinice Kg iz fiskalnog drivera - fiksno postavljena.

Na taj način će se poslati ispravna mjerna jedinica u datoteci za print. Preostale vrijednosti od 10 do 14 za mjerne jedinice u fiskalnoj memoriji, koristimo za definisanje proizvoljnih mjernih jedinica, npr. ako želimo dodati novu mjernu jedinicu "SED" kao sedmica, unijećemo mjernu jedinicu prvo kao SD ili neku drugu 2-značnu oznaku u fiskalnu memoriju preko aplikacije HCP Fiscal, upisati je u fiskalni driver sa funkcijom "SAVE to Register", ovu funkciju možete vidjeti na vrhu ove stranice - slika pomoćnog programa HCP Fiscal, panel Measure units, gdje se unose mjerne jedinice u fiskalnu memoriju, mjerna jedinica unešena u fiskalnu memoriju mora biti 2-značna, jer je tako definisano Zakonom o Fiskalizaciji u FBiH, i ukoliko smo u fiskalnoj memoriji unijeli za oznaku SD (sedmica) šifru 14, u Pantheonu u šifrantu Mjernih jedinica, ovu mjernu jedinicu možemo unijeti kao "SED" - sedmica, i u polju fiskalna šifra upisaćemo broj 14, međutim ona će se ispisati na fiskalnom štampaču kao SD, jer je tako unešena u fiskalnu memoriju, i fiskalnom štampaču se šalje fiskalna šifra 14, koja znači ispis mjerne jednice sa oznakom SD.

Bitno je da se mjerne jedinice upisane u fiskalnoj memoriji, poklapaju sa mjernim jedinicima koje se unesu u šifrant Mjenih jedinica, tj. vrijednosti polja fiskalna šifra, i na taj način su mjerne jedinice ispravno postavljene za fiskalni driver HCP Residential Gateway.


PLU šifre, Primjer maloprodajnog fiskalnog računa

PLU šifre se unose u šifrantu artikala na označenom polju sa slike ispod PLU kod (i PLU KOD 2 za prodaju artikala ino-kupcima, NATO vojsci, i sl.) .

Na slici ispod imate primjer kako izgeda jedan POS račun spreman za slanje na fiskalni printer

Te kako izgleda odštampan taj maloprodajni fiskalni račun, na slici ispod

Pored ispisa maloprodajnog fiskalnog računa u PANTHEON-u je i dalje moguć i ispis računa na A4 printer, desnim klikom miša na tipku F8-ispis (ukoliko se ukaže potreba za ovakvim ispisom), a da se pri tome dokument ne potvrdi, dokument se potvrdi lijevim klikom miša na F8 – ispis, time se račun pošalje na fiskalni štamapač.


Načini plaćanja

Kod plaćanja u zavisnosti, da li se plaća gotovinom, kreditnom karticom, vrimanom ili čekom, sa padajućeg menija “Načini plaćanja, na POS-u nakon pritiska na

tipku F7-plaćanje, označite vrstu plaćanja kojom se izvršava plaćanje.

Ukoliko određeni način plaćanja nije na listi, to podešavanje izvršite u šifrantu „Načini plaćanja", koji se nalazi na ,sljedećoj lokaciji,

gdje za „Slip tip“,kod gotovine označite – 0, kod čeka – 1, kod kartice – 2, kod virmana-3.

pod Vrsta za sve načine plaćanja ostavite - G-Gotovina, jer je kontrola za vrste plaćanja pod Slip Tip.


Izvještaji, dodatne funkcije
Na meniju čarobnjaka

Presjek stanja - X izvještaj (smjena operatera-neobavezan), Zaključi fiskalni printer - Z izvještaj (Dnevni izvještaj)- obavezan), i

Periodični izvještaj od - do (obavezan 1x mjesečno, krajem mjeseca 30/31 u mjesecu).

Depozit stavi, Depozit uzmi (uplata depozita i isplata depozita iz blagajne, npr. uplata 100, isplata sa -100, ukoliko na početku dana

reklamirate račun, a nemate dovoljno sredstava uplaćeno u fiskalnoj memoriji, nećete moći izvršiti reklamiran račun, i zato ćete

morati uplatiti depozit u iznosu reklamiranog računa ili većem iznosu)

Od verzije Pantheon-a 55, 53.00 , dostupna je i funkcija duplikata fiskalnog računa , ovu funkciju pronaći ćete na čarobnjaku, kao na slici ispod

Lijevim klikom miša na ovu funkciju, otvara se prozor gdje upisujete broj fiskalnog računa, za koji želite ispisati duplikat fiskalnog računa,

pritisnete na tipku pošalji i potvrdite slanje ispisa duplikata fiskalnog računa na fiskalni štampač.

Od verzije PANTHEON55, 56.00, dostupna je i funkcija "Izvještaja po artiklima" na čarobnjaku na VD POS, koju koristite za ispis Izvještaja o

prodatim artiklima u toku dana na fiskalnom štampaču, ovo je neobavezni izvještaj, koji ispišete ukoliko imate potrebu za istim, jednostavnim

klikom na opciju "Izvještaj po artiklima", ispiše se Izvještaj iz fiskalne memorije o prodatm artiklima u toku dana.

, pronaći ćete dodatne funkcije kao što su ispis računa, polaganje i uzimanje depozita, otvaranje ladice, te izvještaje kao što su


Maloprodajni reklamirani fiskalni račun

Storno maloprodajnog fiskalnog računa (maloprodajni reklamirani fiskalni račun - povrat robe)

Storno maloprodajnog fiskalnog računa, odnosno maloprodajni reklamirani račun izvršavamo na sljedeći način. Ukoliko želimo prethodno ispisani maloprodajni fiskalni račun 11-320-000427 reklamirati - izvršiti povrat robe

to ćemo učiniti tako što pritisnemo na tipku F6 - Storno, otvara se novi panel "Storno", gdje upišete neophodne podatke, kao što su Korisnik, lozinka, te veoma bitan podatak za ispisivanje reklamiranog računa "broj fisk. računa", kojeg u ovom slučaju reklamiramo, nakon toga pritisnemo tipku Storno.

Pritiskom na tipku Storno, otvara se novi račun (11-320-000428), sa storniranim pozicijama (minus) prethodnog maloprodajnog fiskalnog računa, nakon toga pritisnemo tipku F7-plaćanje, označimo način plaćanja kojim je izvršen prethodno maloprodajni fiskalni račun, zatim kliknemo na tipku F8-Ispis i na taj način ispišemo maloprodajni reklamirani fiskalni račun

Slika ispod prikazuje ispisan maloprodajni reklamirani fiskalni račun, koji smo iznad kreirali.


Zaokruživanje

Zbog zahtjeva fiskalnog drivera HCP Residential Gateway za zaokruživanjem izračuna cijena na 2 decimale, neophodno je ovome prilagoditi i PANTHEON, kako ne bi dolazilo do toga da t otal plaćanja nije isti kao što štampač zaokružuje, i onda se dešava da račun ostaje otvoren i čekaće na uplatu dodatnih 0.01 KM ili slično.

Ovo se dešava ukoliko u Administratorskoj konzoli u postavkama za Preduzeće\Zaokruživanje imate postavljeno zaokruživanje izračuna pozicija na POS-u i vrijednosti na 4 decimale i sl.

Na ovaj način bi trebalo biti podešeno zaokruživanje u AK \Postavke\Parametri programa\Preduzeće\Zaokruživanje

Postavke zaokruživanja zapisuju se u glavi dokumenta tako da ako testirate na jednom već otvorenom dokumentu i promijenite postavke zaokruživanja, na istom dokumentu će važiti stare postavke, tako da je potrebno otvoriti novi dokument da bi vidjeli promjene.


Više o Fiskalizaciji u FBiH

Korisne Informacije o Fiskalizaciji u FBiH

Fiskalizacija FBiH

PANTHEON ERP za sve djelatnosti

Više informacija o FP555 BA i Best BA


Page0003

Na panelu
POS printer
nisu potrebna dodatna podešavanja, pored zadanih.
Na panelu
Prikazni ekran (display),
nisu potrebna dodatna podešavanja, pored zadanih.
Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju
„Upotreba fiskalnog printera“,
sa padajućeg menija
Fiskalni printer
, odabrati


Page0004

„

Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju

"Mikroelektronika professional
“, te pored navedenog označiti putanju direktorija za print u
folder
C:\temp
i putanju direktorija za log „
C:\temp" “,to je
folder gdje se šalju file-ovi za
printanje i gdje se smještaju log file-ovi. Dodatna podešavanja kao što su
podešavanje prelaska
na ljetno ili zimsko računanje vremena, poreske stope, jedinice mjere, tekst za kupca i naziv trgovine , možete
izvršiti sa tipkama koje se nalaze desno na ovom prozoru.
Opciono možete izabrati upotrebu numeričkih PLU šifri
u zavisnosti od vaših potreba, ukoliko

ova opcija nije uključena, koriste se alfanumeričke šifre, odnosno šifre iz PANTHEON-a.


Napomene

.
*Na kraju nekoliko napomena:
Zbog načina rada F-linka HP i FP Hybrid , u PANTHEON-u je urađeno takvo rješenje da se naziv artikla koji se šalje iz Pantheona na fiskalni štampač za veleprodaju
sastoji samo iz naziva artikla + /JM, bez slanja kombinacije šifra+naziv, jer za FP Hybrid jednoznačnost naziva artikla koji se šalje na ispis nije bitna.

Naziv artikla za FP Hybrid je maksimalne dužine 30 znakova, i Pantheon siječe naziv artikla na 30 znakova, ukoliko je dužina naziva artikla koji se šalje na FP Hybrid

veća od 30 znakova (naziv artikla za FP Hybrid = 27 znakova naziva artikla iz Pantheona + 3 znaka /JM = 30 znakova).

To bi na primjeru jednog artikla sa nazivom koji sadrži više od 30 znakova, ovako izgledalo:

Ukoliko je Naziv artikla: ¨sok cappy juice 2L mix vitaminski 2l pakovanje¨ i prodajemo 2L ovog artikla, to će na ispisu računa biti u ovom formatu

sok cappy juice 2L mix vita/L.

Znači makimalan broj karaktera koji se ispisuje na računu i dalje ostaje 27 , zbog F-linka HP i veleprodaje, jer on prima maksimalno 30 karaktera.
27+/JM (/jedinica mjere – 3 znaka) ! FP Hybrid također bi ovo i samostalno radio ukoliko mu se pošalje naziv duži od 30 znakova, on bi ga sijekao na 30 znakova.


Page0010

Kao i što je prethodno navedeno u PANTHEON-u je omogućen rad kako sa PLU šiframa (numeričkim), tako i sa PA šiframa

(alfanumeričkim), kako to izgleda u fiskalnom printeru (memoriji fiskalnog printera) - unos ovih artikala, prikazano je na slici ispod:
Artikli sa
PLU šiframa (numeričkim)
Artikli sa
PA šiframa (alfanumeričkim)
Rad sa plu šiframa je brži u odnosu na rad sa pa šiframa, što je jedna od prednosti korištenja plu šifara, koje unosite
u šifrant artikala u polje predviđeno za plu šifre, mada je na korisniku da odluči koje će šifre koristiti u svom radu.